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Agilent LogicWave Help

Agilent LogicWave HelpAgilent LogicWave HelpAgilent LogicWave HelpAgilent LogicWave Help

Includes the following types of information:
� Getting Started - Quickly shows how to make basic measurements.
� Measurement Examples - How common measurements are performed

with the logic analyzer.
� Task Guide - Shows how to perform logic analyzer tasks.
� Reference - Describes windows, commands, dialogs, and error messages.
� Concepts - Describes basic logic analysis concepts and answers

frequently asked questions about LogicWave.
� Setup and Quick Reference - Shows how to connect the logic analyzer to

your PC and install software.
� Glossary - Defines terms used in the LogicWave logic analyzer and its

help.
See AlsoSee AlsoSee AlsoSee Also

� Technical Support
� LogicWave Home Page

Getting Started

Getting StartedGetting StartedGetting StartedGetting Started

Quickly shows how to make basic measurements.
Making a Basic MeasurementMaking a Basic MeasurementMaking a Basic MeasurementMaking a Basic Measurement

� Step 1. Start LogicWave
� Step 2. Connect the logic analyzer probes
� Step 3. Run a measurement

Performing Other Tasks and Measurements in Timing ModePerforming Other Tasks and Measurements in Timing ModePerforming Other Tasks and Measurements in Timing ModePerforming Other Tasks and Measurements in Timing Mode

� Step 4. Set up the asynchronous sampling (timing) mode
� Step 5. Assign bus/signal names
� Step 6. Re-arrange buses and signals
� Step 7. Trigger on a signal edge
� Step 8. Trigger on sequential events
� Step 9. Trigger on a pulse
� Step 10. Measure time using markers
� Step 11. Trigger on a bus value in timing mode
� Step 12. Zoom in on data (change the time/division)
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Performing Other Tasks and Measurements in State ModePerforming Other Tasks and Measurements in State ModePerforming Other Tasks and Measurements in State ModePerforming Other Tasks and Measurements in State Mode

� Step 13. Set up the synchronous sampling (state) mode
� Step 14. Trigger on a bus value in state mode
� Step 15. Trigger on the Nth occurrence of a value
� Step 16. Trigger on sequential state events
� Step 17. Find a value in the captured data
� Step 18. Save the data file, and exit

Making a Basic Measurement

Step 1. Start LogicWaveStep 1. Start LogicWaveStep 1. Start LogicWaveStep 1. Start LogicWave

1. Choose Start->Programs->Agilent LogicWave->Agilent LogicWave.

2. Create a new configuration.
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3. Select the asynchronous sampling (timing) mode.

The Agilent LogicWave window opens.
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Step 2. Connect the logic analyzer probesStep 2. Connect the logic analyzer probesStep 2. Connect the logic analyzer probesStep 2. Connect the logic analyzer probes

1. Connect the probe cable to the logic analyzer.

2. Probe the device under test.

Step 3. Run a measurementStep 3. Run a measurementStep 3. Run a measurementStep 3. Run a measurement

Performing Other Tasks and Measurements in Timing Mode

Step 4. Set up the asynchronous sampling (timing) modeStep 4. Set up the asynchronous sampling (timing) modeStep 4. Set up the asynchronous sampling (timing) modeStep 4. Set up the asynchronous sampling (timing) mode
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Step 5. Assign bus/signal namesStep 5. Assign bus/signal namesStep 5. Assign bus/signal namesStep 5. Assign bus/signal names

Step 6. Re-arrange buses and signalsStep 6. Re-arrange buses and signalsStep 6. Re-arrange buses and signalsStep 6. Re-arrange buses and signals

Step 7. Trigger on a signal edgeStep 7. Trigger on a signal edgeStep 7. Trigger on a signal edgeStep 7. Trigger on a signal edge

Step 8. Trigger on sequential eventsStep 8. Trigger on sequential eventsStep 8. Trigger on sequential eventsStep 8. Trigger on sequential events

Step 9. Trigger on a pulseStep 9. Trigger on a pulseStep 9. Trigger on a pulseStep 9. Trigger on a pulse

Step 10. Measure time using markersStep 10. Measure time using markersStep 10. Measure time using markersStep 10. Measure time using markers

Step 11. Trigger on a bus value in timing modeStep 11. Trigger on a bus value in timing modeStep 11. Trigger on a bus value in timing modeStep 11. Trigger on a bus value in timing mode

Step 12. Zoom in on data (change the time/division)Step 12. Zoom in on data (change the time/division)Step 12. Zoom in on data (change the time/division)Step 12. Zoom in on data (change the time/division)

Performing Other Tasks and Measurements in State Mode

Step 13. Set up the synchonous sampling (state) modeStep 13. Set up the synchonous sampling (state) modeStep 13. Set up the synchonous sampling (state) modeStep 13. Set up the synchonous sampling (state) mode

Step 14. Trigger on a bus value in state modeStep 14. Trigger on a bus value in state modeStep 14. Trigger on a bus value in state modeStep 14. Trigger on a bus value in state mode

Step 15. Trigger on the Nth occurrence of an eventStep 15. Trigger on the Nth occurrence of an eventStep 15. Trigger on the Nth occurrence of an eventStep 15. Trigger on the Nth occurrence of an event
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Step 16. Trigger on sequential state eventsStep 16. Trigger on sequential state eventsStep 16. Trigger on sequential state eventsStep 16. Trigger on sequential state events

Step 17. Find a value in the captured dataStep 17. Find a value in the captured dataStep 17. Find a value in the captured dataStep 17. Find a value in the captured data

Measurement Examples
Measurement ExamplesMeasurement ExamplesMeasurement ExamplesMeasurement Examples

How common measurements are performed with the logic analyzer.
� To trigger on a stable pattern
� To trigger on an edge during a valid pattern
� To trigger on edges that are too close or too far
� To trigger when a signal or pattern stops
� To trigger if a pattern doesn't follow an edge
� To trigger on a pulse duration
� To trigger on the Nth occurrence of an event
� To trigger on a sequence of state events
� To capture execution up to a failure or halt

To trigger on a stable patternTo trigger on a stable patternTo trigger on a stable patternTo trigger on a stable pattern

Possible UsesPossible UsesPossible UsesPossible Uses

� To wait for all status lines to finish transitioning before triggering.
� To filter out spurious triggers because of transitions that occur when the

device under test's state machine is indeterminate.
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ProcedureProcedureProcedureProcedure

1. Click the  sampling setup button and set up timing mode sampling.

2. Select the bus that you want to trigger on.
3. Choose the bus value trigger.

4. In the Bus Trigger dialog, enter the value to trigger on.
5. Select the ">" operator.
6. Enter the time that the pattern must be stable for.

With the "<" operator, the minimum time is either twice the sample period
or the absolute minimum of 16 ns.  With the ">" operator, the minimum
time is either equal to the sample period or the absolute minimum of 8 ns.
The entered time will be rounded to a multiple of the sample period.

7. Click OK.
8. Click the  run single measurement button.

See AlsoSee AlsoSee AlsoSee Also

� To select a timing or state analyzer
� To set up timing mode triggers
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To trigger on an edge during a valid patternTo trigger on an edge during a valid patternTo trigger on an edge during a valid patternTo trigger on an edge during a valid pattern

Possible UsesPossible UsesPossible UsesPossible Uses

� To capture a memory chip's select line at a given address.
� To view the timing of a write signal to a peripheral.

ProcedureProcedureProcedureProcedure

1. Click the  sampling setup button and set up timing mode sampling.

2. Specify the valid bus pattern.
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3. Specify the edge.

4. Click the  run single measurement button.
See AlsoSee AlsoSee AlsoSee Also

� To select a timing or state analyzer
� To set up timing mode triggers

To trigger on edges that are too close or too farTo trigger on edges that are too close or too farTo trigger on edges that are too close or too farTo trigger on edges that are too close or too far

Possible UsesPossible UsesPossible UsesPossible Uses

� To check DRAM row/column address strobe timing.
� To detect a handshake violation.
� To trigger on incorrect control signal generation from a Programmable

Logic Device (PLD).
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ProcedureProcedureProcedureProcedure

1. Click the  sampling setup button and set up timing mode sampling.

2. Specify the first signal edge to look for.

3. Choose the trigger "Add 'Followed by' condition" command.

4. Specify the second signal edge to look for.
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5. Click the time specification button at the top of the trigger column.

6. To trigger on edges too close, select "Less than time", or to trigger on
edges too far select "Greater than time" in the Time Period Setup dialog;
then, enter the time limit.

7. Click the  run single measurement button.
See AlsoSee AlsoSee AlsoSee Also

� To select a timing or state analyzer
� To set up timing mode triggers

To trigger when a signal or pattern stopsTo trigger when a signal or pattern stopsTo trigger when a signal or pattern stopsTo trigger when a signal or pattern stops

Possible UsesPossible UsesPossible UsesPossible Uses

� To trigger when signals are inactive for too long a time.
� To check when execution leaves an address range.
� To check when expected variable values stop being written.
� To capture what leads up to an unexpected condition.
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ProcedureProcedureProcedureProcedure

1. Click the  sampling setup button and set up timing mode sampling.

2. Specify the signal or bus pattern that you want to check.

3. Choose the trigger "Add 'Followed by' condition" command.

4. Specify the same signal or bus pattern in the second trigger column.
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5. Click the time specification button at the top of the trigger column.

6. In the Time Period Setup dialog, select "Greater than time" and enter the
time that indicates that the signal or pattern has stopped.

7. Click the  run single measurement button.
See AlsoSee AlsoSee AlsoSee Also

� To select a timing or state analyzer
� To set up timing mode triggers

To trigger if a pattern doesn't follow an edgeTo trigger if a pattern doesn't follow an edgeTo trigger if a pattern doesn't follow an edgeTo trigger if a pattern doesn't follow an edge

Possible UsesPossible UsesPossible UsesPossible Uses

� To measure interrupt response time.
� To trigger when expected data does not appear on the data bus from a

remote device when requested.
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ProcedureProcedureProcedureProcedure

1. Click the  sampling setup button and set up timing mode sampling.

2. Specify the edge to look for.

3. Choose the trigger "Add 'Followed by' condition" command.

4. Specify the bus pattern that should follow the edge.
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5. Click the time specification button at the top of the trigger column.

6. In the Time Period Setup dialog, select "Greater than time" and enter the
time within which the pattern should occur.

7. Click the  run single measurement button.
See AlsoSee AlsoSee AlsoSee Also

� To select a timing or state analyzer
� To set up timing mode triggers

To trigger on a pulse durationTo trigger on a pulse durationTo trigger on a pulse durationTo trigger on a pulse duration

Possible UsesPossible UsesPossible UsesPossible Uses

� To test minimum and maximum pulse limits.
� To verify that all pulses controlling a mechanical device fall within

specifications.
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ProcedureProcedureProcedureProcedure

1. Click the  sampling setup button and set up timing mode sampling.

2. Select the signal whose pulse you wish to check.
3. Choose the "Pulse Duration..." trigger.

4. In the Pulse Width dialog, select the type of pulse and enter the duration.

With the "<" operator, the minimum time period is either twice the sample
period or the absolute minimum of 16 ns.  With the ">" operator, the
minimum time period is either equal to the sample period or the absolute
minimum of 8 ns.  The entered time period will be rounded to a multiple of
the sample period.

5. Click OK.
6. Click the  run single measurement button.

See AlsoSee AlsoSee AlsoSee Also

� To select a timing or state analyzer
� To set up timing mode triggers
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� To use the X and O markers
To trigger on the Nth occurrence of an event (in state mode)To trigger on the Nth occurrence of an event (in state mode)To trigger on the Nth occurrence of an event (in state mode)To trigger on the Nth occurrence of an event (in state mode)

Possible UsesPossible UsesPossible UsesPossible Uses

� To trigger on the 50th occurrence of a digital signal processing (DSP)
subroutine.

� To trigger on the 3rd write to a specific memory address.
ProcedureProcedureProcedureProcedure

1. Click the  sampling setup button and set up state mode sampling.

2. Set up the bus value or signal value trigger.
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3. Click "Trigger on..." and select "Occurrence count = N ...".

4. In the Trigger Occurrence Count dialog, enter the number of times the
event must occur before the logic analyzer triggers.

5. Click the  run single measurement button.
See AlsoSee AlsoSee AlsoSee Also

� To select a timing or state analyzer
� To set up state mode triggers

To capture execution up to a failure or haltTo capture execution up to a failure or haltTo capture execution up to a failure or haltTo capture execution up to a failure or halt

Possible UsesPossible UsesPossible UsesPossible Uses

� To store and display all activity leading up to a system crash.
� To run the logic analyzer indefinitely so that you can stop the

measurement and observe system activity at your discretion.
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ProcedureProcedureProcedureProcedure

1. Click the  sampling setup button and set up state mode sampling.

Use a clock signal that will stop when the failure or halt occurs.
2. Also in the Setup Properties dialog, select "90% - End" so that when the

sampling clock stops, you will have captured as many states as possible.

3. Set up to trigger on a bus or signal value that cannot occur.

4. Click the  run single measurement button.
5. When the failure or halt occurs, click the  stop acquisition button.

The data captured before the failure or halt will be displayed.
See AlsoSee AlsoSee AlsoSee Also

� To select a timing or state analyzer
� To set up state mode triggers
� To specify the trigger position
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Task Guide

Task GuideTask GuideTask GuideTask Guide

Shows how to perform logic analyzer tasks.
� Connecting Logic Analyzer Probes - Shows how to physically connect

logic analyzer probes to your device under test.
� Capturing the Data - Shows how to select the type of logic analyzer and

set up measurements.
� Displaying the Data - Shows different ways of displaying captured data.
� Printing/Exporting Data - Shows how to print captured data and export it in

ASCII format.
� Triggering Other Instruments - Shows how to trigger oscilloscopes with the

logic analyzer.

Connecting Logic Analyzer Probes

Connecting Logic Analyzer ProbesConnecting Logic Analyzer ProbesConnecting Logic Analyzer ProbesConnecting Logic Analyzer Probes

How to physically connect logic analyzer probes to your device under test.
� To physically connect logic analyzer probes
� To use the probe test contact
� To set the logic analyzer threshold voltage
� To assign bus/signal names to the logic analyzer probes
� To define symbols for particular bus/signal values

See AlsoSee AlsoSee AlsoSee Also

In addition to the general-purpose probes supplied with LogicWave, you can also
plug  logic analyzer probe cables (and perhaps termination adapters) directly into
connectors that have been designed into a device under test.  Refer to the
Agilent logic analyzer probing accessories information on the World Wide Web
at:

� Accessories
To physically connect logic analyzer probesTo physically connect logic analyzer probesTo physically connect logic analyzer probesTo physically connect logic analyzer probes

� Connecting to the Signal
� Grounding
� Assembling the Probing System

General-purpose probing requires connecting probe leads to individual signal
lines. It is the most common method and is the most flexible. Because of the
passive design of the probe, there are no active circuits at the outer end of the
cable.
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The probing system is similar to those of high-frequency oscilloscopes.  It
consists of a series RC network at the probe tip and a shielded resistive
transmission line.

The advantages of this are:
� high input impedance
� signal ground at the probe tip to minimize reactive loading of high-speed

timing signals
� inexpensive, removable probe tip assemblies

Connecting to the SignalConnecting to the SignalConnecting to the SignalConnecting to the Signal

The signal and ground leads can be connected directly to the device under test.
This requires installing 0.63 mm (0.025 inch) square pins, or round pins with a
diameter between 0.66 and 0.84 mm (0.026 and 0.033 inch) directly on the
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board. You can also use an IC test clip with pins with those dimensions.
You can also connect the leads using grabbers, which have small enough hooks
to fit around adjacent IC pins, by using surface-mount grabbers designed for fine
surface-mounted component leads, or by using wedge probe adapters.  You can
find more information on Agilent logic analyzer probing accessories on the World
Wide Web at:

� Accessories
GroundingGroundingGroundingGrounding

Proper grounding will improve the signal quality and is essential for high-speed
measurements. Each pod has a pod ground lead, which must be used. You can
use only this ground, but the ground path will not be the same length as the
signal path.
When probing signals with rise and fall times of 1 ns or less, ground each probe
lead with a 2-inch ground lead as well as grounding the pod with the pod ground
lead. This yields a grounding path equal to the signal path.
For good results with lower-speed measurements, ground not only the pod but
every third or fourth lead.
Assembling the Probing SystemAssembling the Probing SystemAssembling the Probing SystemAssembling the Probing System

1. Connect the probing assembly to the probe cable.
2. If you have extra leads, disconnect individual probe leads by pushing on

the latch at the lead base with a ballpoint pen.
3. Connect grabbers to the leads by slipping the end of the lead over the

recessed pin located in the side of the grabber.
See AlsoSee AlsoSee AlsoSee Also

� Signal Requirements
� About the Probe Cable

To set the logic analyzer threshold voltageTo set the logic analyzer threshold voltageTo set the logic analyzer threshold voltageTo set the logic analyzer threshold voltage

1. Open the Sampling Setup dialog.  (You can do this by clicking the 
sampling setup button, or you can choose the Data->Sampling Setup...
command.)

2. Click the Thresholds... button.
3. In the Threshold dialog, select the type of signals that each logic analyzer

pod is probing (TTL, CMOS(5V), CMOS(3.3V), or ECL) or "user defined"
to specify a threshold voltage level.
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To assign bus/signal names to the logic analyzer probesTo assign bus/signal names to the logic analyzer probesTo assign bus/signal names to the logic analyzer probesTo assign bus/signal names to the logic analyzer probes

� To assign bus/signal names
� To add bus/signal names
� To delete bus/signal names
� To delete all bus/signal names

To assign bus/signal namesTo assign bus/signal namesTo assign bus/signal namesTo assign bus/signal names

1. Open the Bus/Signal Setup dialog. You can do this by clicking the 
bus/signal setup button on the standard toolbar, or you can choose the
Bus/Signal->Setup... command.

To add bus/signal namesTo add bus/signal namesTo add bus/signal namesTo add bus/signal names

1. Click the Add Bus/Signal button.
2. Click on the Bus/Signal name, and type the new name.
3. Select the channel(s) from Pod 1, Pod 2, or Clock.

4. Click OK.
When assigning bus names, the most significant bits of the bus are always the
higher-order channel numbers.
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To delete bus/signal namesTo delete bus/signal namesTo delete bus/signal namesTo delete bus/signal names

1. Select the bus/signal.
2. Click the Delete Bus/Signal button.
3. Click OK.

To delete all bus/signal namesTo delete all bus/signal namesTo delete all bus/signal namesTo delete all bus/signal names

1. Click the Delete All button.
2. Click OK.

See AlsoSee AlsoSee AlsoSee Also

� Bus/Signal Setup
� Standard Toolbar

Capturing the Data

Capturing the DataCapturing the DataCapturing the DataCapturing the Data

How to set up logic analyzer measurements.
� To select a timing or state analyzer
� To start/stop measurements
� To set up timing mode triggers (in Waveform view)
� To set up state mode triggers (in Listing view)
� To specify the trigger position
� To recall logic analyzer setups

To select a timing or state analyzerTo select a timing or state analyzerTo select a timing or state analyzerTo select a timing or state analyzer

� To select the timing analyzer
� To set the timing analyzer sample period
� To select the state analyzer
� To set up the state analyzer sampling clock

A timing analyzer is a logic analyzer that samples based on an internal clock
signal.  This kind of sampling is also known as asynchronous sampling.
A state analyzer is a logic analyzer that samples based on a clock signal (or
signals) from the device under test.  Typically, the signal used to set up sampling
is a state machine or microprocessor clock signal.  This kind of sampling is also
known as synchronous sampling.
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To select the timing analyzerTo select the timing analyzerTo select the timing analyzerTo select the timing analyzer

1. Click the  sampling setup button, or choose the Data->Sampling
Setup... command.

2. In the Sampling Setup dialog, select the asynchronous sampling option.

To set the timing analyzer sample periodTo set the timing analyzer sample periodTo set the timing analyzer sample periodTo set the timing analyzer sample period

1. Click the  sampling setup button, or choose the Data->Sampling
Setup... command.

2. In the Timing Mode area of the Sampling Setup dialog, increase or
decrease the Sample Period. To capture signal level changes reliably, the
sample period should be less than half (many engineers prefer one-fourth)
of the period of the fastest signal you want to measure. Time interval
measurements are made by counting the number of samples in the
desired waveform area.  These measurements are made to a +/- one
sample error, so measurement accuracy is improved if the number of
samples is maximized.  For example, a 100 ns pulse width measured at a
sampling period of 10 ns will be made with an accuracy of +/- 10 ns or +/-
10%.  Increasing the sampling speed to a sampling period of 4 ns will
improve the accuracy to +/- 4%.  The resulting measurement duration
changes accordingly.

To select the state analyzerTo select the state analyzerTo select the state analyzerTo select the state analyzer

1. Click the  sampling setup button, or choose the Data->Sampling
Setup... command.

2. In the Sampling Setup dialog, select the synchronous sampling option.
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3. Select the logic analyzer's CLK channel and signal edge that should be
used as the sampling clock.

To set up the state analyzer sampling clockTo set up the state analyzer sampling clockTo set up the state analyzer sampling clockTo set up the state analyzer sampling clock

1. Click the  sampling setup button, or choose the Data->Sampling
Setup... command.

2. In the State Mode area of the Sampling Setup dialog, select the logic
analyzer clock inputs used to generate the state sampling clock.

See AlsoSee AlsoSee AlsoSee Also

� State analysis vs. timing analysis
� State analyzer sampling, OR'ed clocks
� State analyzer sampling, qualified clock

To start/stop measurementsTo start/stop measurementsTo start/stop measurementsTo start/stop measurements

� To start a measurement
� To stop a measurement

To start a measurementTo start a measurementTo start a measurementTo start a measurement

1. Click the  run single measurement or  run repetitive measurement
buttons or choose the Run/Stop->Single Measurement or Run/Stop-
>Repetitive Measurement commands The  run single measurement
button will save the captured data to trace memory one time. The  run
repetitive measurement button will save the captured data to trace
memory repetitively.

To stop a measurementTo stop a measurementTo stop a measurementTo stop a measurement

1. Click the  stop acquisition button or choose the Run/Stop->Stop
command.

To set up timing mode triggers (in Waveform view)To set up timing mode triggers (in Waveform view)To set up timing mode triggers (in Waveform view)To set up timing mode triggers (in Waveform view)

� To trigger on signal values
� To trigger on bus values
� To trigger on sequential events
� To erase the trigger setup
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To trigger on signal valuesTo trigger on signal valuesTo trigger on signal valuesTo trigger on signal values

1. Click the signal's Trigger button.

2. Keep clicking to cycle through the different types of triggers. Or: Select the
type of trigger from the Trigger menu. Or: Click the Trigger button pull-
down to select the trigger type from a menu.

To trigger on bus valuesTo trigger on bus valuesTo trigger on bus valuesTo trigger on bus values

1. Click the bus' Trigger button.

Or: Select the type of trigger from the Trigger menu. Or: Click the Trigger
button pull-down to select the trigger type from a menu.
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2. In the Bus Trigger dialog, enter the value to trigger on.

By selecting a different operator, you can also trigger on:
� Any bus value other than the specified value.
� A range of bus values.
� Any bus value outside the specified range.
� A symbol that has been defined for a particular bus value.

To trigger on sequential eventsTo trigger on sequential eventsTo trigger on sequential eventsTo trigger on sequential events

1. Choose "Add 'Followed by' condition" from the trigger menu.
2. Specify the event sequence.

3. In the  Time Period Setup dialog, specify the amount of time between the
events.

To return to a single-level trigger, specify all "don't cares" in the second level (or
choose the Trigger->Reset command); then, choose "Add 'Followed by'
condition" again to uncheck it.

NOTE: "Followed by" triggers will generally be off by one or two samples.
Generally, the logic analyzer's sequencer can't detect the trigger condition until
one or two samples past when the condition actually occurs. This means that, in
the captured data, the trigger point shows up one or two samples past the actual
trigger condition.

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To erase the trigger setupTo erase the trigger setupTo erase the trigger setupTo erase the trigger setup

1. Choose the Trigger->Reset command.
To set up state mode triggers (in Listing view)To set up state mode triggers (in Listing view)To set up state mode triggers (in Listing view)To set up state mode triggers (in Listing view)

� To trigger on signal values
� To trigger on bus values
� To trigger on one of several values
� To trigger on sequential state events
� To trigger on the Nth occurrence of a value
� To erase the trigger setup

To trigger on signal valuesTo trigger on signal valuesTo trigger on signal valuesTo trigger on signal values

1. Click the signal's Trigger button.

2. Keep clicking to cycle through the different types of triggers. Or: Select the
type of trigger from the Trigger menu. Or: Click the Trigger button pull-
down to select the trigger type from a menu.

To trigger on bus valuesTo trigger on bus valuesTo trigger on bus valuesTo trigger on bus values

1. Click the bus' Trigger button.

Or: Select the type of trigger from the Trigger menu. Or: Click the Trigger
button pull-down to select the trigger type from a menu.
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2. In the Bus Trigger dialog, enter the value to trigger on.

By selecting a different operator, you can also trigger on:
� Any bus value other than the specified value.
� A range of bus values.
� Any bus value outside the specified range.
� A symbol that has been defined for a particular bus value.

To trigger on one of several valuesTo trigger on one of several valuesTo trigger on one of several valuesTo trigger on one of several values

1. Click the Trigger on... button, and select Add 'OR' condition.

2. Specify the additional values.

To trigger on sequential state eventsTo trigger on sequential state eventsTo trigger on sequential state eventsTo trigger on sequential state events

1. Click the Trigger on... button, and select Add 'THEN' condition.
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2. Specify the additional state events.

To trigger on the Nth occurrence of a valueTo trigger on the Nth occurrence of a valueTo trigger on the Nth occurrence of a valueTo trigger on the Nth occurrence of a value

1. Specify the signal or bus value to trigger on.
2. Click the Trigger on... button, and select Occurrence count = 1....

You can only trigger on the Nth occurrence of an event in state mode.
3. In the Trigger Occurrence Count dialog, specify which occurrence of the

value to trigger on.

To erase the trigger setupTo erase the trigger setupTo erase the trigger setupTo erase the trigger setup

1. Choose the Trigger->Reset command.
To specify the trigger positionTo specify the trigger positionTo specify the trigger positionTo specify the trigger position

1. Open the Sampling Setup dialog.  (You can do this by clicking the 
sampling setup button, or you can choose the Data->Sampling Setup...
command.)

2. Select the trigger position.

The selections specify the amount of trace memory used for samples
captured before the trigger. When "10% - Start" is selected, 90% of trace
memory is used for samples captured after the trigger. When "90% - End"
is selected, 90% of trace memory is used for samples captured before the
trigger.
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
NOTE: The trigger position setting works differently in the state and timing
sampling modes.
In the timing mode, the analyzer won't begin to look for the trigger until it has
filled the pre-trigger portion of trace memory, thereby guaranteeing that the
trigger will be positioned correctly in the captured data.
In the state mode, regardless of the trigger position setting, the analyzer will
begin to look for a trigger after one state has been stored. Therefore, it is
possible for the trigger to be the second state, even when the 90% trigger
position is selected.


To recall logic analyzer setupsTo recall logic analyzer setupsTo recall logic analyzer setupsTo recall logic analyzer setups

� To save a logic analyzer setup
� To open a logic analyzer setup

To save a logic analyzer setupTo save a logic analyzer setupTo save a logic analyzer setupTo save a logic analyzer setup

1. Click the  save button or choose the File->Save or File->Save As...
commands.

2. If the logic analyzer setup file is new, name the file in the file browser
dialog.

Secondary Display windows are not saved.
To open a logic analyzer setupTo open a logic analyzer setupTo open a logic analyzer setupTo open a logic analyzer setup

1. Click the  open button or choose the File->Open... command.
2. Select the logic analyzer setup file from the file browser dialog.

Secondary Display windows are not restored.

Displaying the Data

Displaying the DataDisplaying the DataDisplaying the DataDisplaying the Data

How to display captured data.
� To scale the waveform display
� To find a value in the captured data
� To use the X and O markers
� To group signals into buses
� To hide signals/buses
� To rename signals/buses
� To reorder signals/buses in the display
� To specify waveform colors
� To display absolute time information
� To display relative time information
� To display symbols in captured data
� To see an additional view of the captured data
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To scale the waveform displayTo scale the waveform displayTo scale the waveform displayTo scale the waveform display

� To zoom in on the data
� To zoom out on the data
� To undo the last zoom command

To zoom in on the dataTo zoom in on the dataTo zoom in on the dataTo zoom in on the data

� Lower the time-per-division on the display.

� Drag the mouse pointer around the area you want to zoom in on.

� Choose the Data->Zoom In command.
To zoom out on the dataTo zoom out on the dataTo zoom out on the dataTo zoom out on the data

� Raise the time-per-division on the display.

� Choose the Data->Zoom Out command.
To undo the last zoom commandTo undo the last zoom commandTo undo the last zoom commandTo undo the last zoom command

� Click the  zoom undo button on the Data Toolbar, or choose the Data-
>Undo Last Zoom command.

To find a value in the captured dataTo find a value in the captured dataTo find a value in the captured dataTo find a value in the captured data

1. Click the  find data value button or choose the Data->Find Data Value...
command.

2. In the Find dialog, select the bus or signal name and enter the value you
want to locate.

3. Click the Next or Previous buttons.
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To use the X and O markersTo use the X and O markersTo use the X and O markersTo use the X and O markers

� To place markers in the display
� To go to a marker

The X and O markers can be moved around in the captured data to measure
time between events.  For example, you can measure the time between edges
that appear in the captured data, or you can measure the width of a pulse that
appears in the captured data.
The T marker shows the trigger point which is a fixed point in the captured data.

NOTE: You can drag the T marker like the X and the O markers, but doing so
moves all the captured data (and the X and O markers) relative to the time line
and changes the delay.  Going to the T marker repositions the marker and the
captured data so that the delay is zero.


To place markers in the displayTo place markers in the displayTo place markers in the displayTo place markers in the display

� Drag the X or O markers to place them at specific locations. The X and O
markers are always in the data display, as is the time between markers.

To go to a markerTo go to a markerTo go to a markerTo go to a marker

� Click the  goto X marker or  goto O marker buttons, or choose the
Data->Go To->X Marker or Data->Go To->O Marker commands.
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To group signals into busesTo group signals into busesTo group signals into busesTo group signals into buses

� To group signals
� To ungroup bus signals

To group signalsTo group signalsTo group signalsTo group signals

1. Select the signals that make up the bus (using Click, Shift+Click, and
Ctrl+Click on the signal names).

2. Choose the Bus/Signal->Group Into Bus command, or type Ctrl+g.

3. Enter the name of the bus.

To ungroup bus signalsTo ungroup bus signalsTo ungroup bus signalsTo ungroup bus signals

1. Select the bus.
2. Choose the Bus/Signal->Ungroup from Bus command, or type Ctrl+u.

See AlsoSee AlsoSee AlsoSee Also

� To assign bus/signal names to the logic analyzer probes
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To hide signals/busesTo hide signals/busesTo hide signals/busesTo hide signals/buses

� To hide signals/buses
� To show hidden signals/buses

To hide signals/busesTo hide signals/busesTo hide signals/busesTo hide signals/buses

1. Select the signals/buses you want to hide (using Click, Shift+Click, and
Ctrl+Click on the signal names).

2. Choose the Bus/Signal->Format Row->Hide command.
To show hidden signals/busesTo show hidden signals/busesTo show hidden signals/busesTo show hidden signals/buses

1. Choose the Bus/Signal->Format Row->Show All command.
See AlsoSee AlsoSee AlsoSee Also

� To assign bus/signal names to the logic analyzer probes
To rename signals/busesTo rename signals/busesTo rename signals/busesTo rename signals/buses

1. Select the signal/bus name.
2. Click on the selected signal name, or choose the Bus/Signal->Rename

command.
3. In the resulting text field, type in the new signal name.

To reorder signals/buses in the displayTo reorder signals/buses in the displayTo reorder signals/buses in the displayTo reorder signals/buses in the display

1. In the main window, select the signal or bus name.
2. Drag the signal or bus to its new location.

To display absolute time informationTo display absolute time informationTo display absolute time informationTo display absolute time information

� Click the T(relative) button and select Time Absolute.

The absolute time from the trigger state is displayed.
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To display relative time informationTo display relative time informationTo display relative time informationTo display relative time information

� Click the T(absolute) button and select Time Relative.

The relative time between captured states is displayed.

To see an additional view of the captured dataTo see an additional view of the captured dataTo see an additional view of the captured dataTo see an additional view of the captured data

� Choose the Window->Secondary Waveform Display command, or choose
the Window->Secondary Listing Display command. You can use the
additional view to see data captured in state mode as waveforms, to see
data captured in timing mode as numerical values, or to view different
areas of the captured data.
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Printing/Exporting Data

Printing/Exporting DataPrinting/Exporting DataPrinting/Exporting DataPrinting/Exporting Data

How to move captured data to and from other PC programs.
� To print the displayed data
� To export data in ASCII format

To print the displayed dataTo print the displayed dataTo print the displayed dataTo print the displayed data

� To print data
� To select the printer and the page format
� To preview the printed output

To print dataTo print dataTo print dataTo print data

� Click the  print button, or choose the File->Print... command.
To select the printer and the page formatTo select the printer and the page formatTo select the printer and the page formatTo select the printer and the page format

� Choose the File->Page Setup... command.
To preview the printed outputTo preview the printed outputTo preview the printed outputTo preview the printed output

� Choose the File->Print Preview... command.
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To export data in ASCII formatTo export data in ASCII formatTo export data in ASCII formatTo export data in ASCII format

1. Choose the File->Export... command.
2. In the Export dialog, specify the name of the destination file.

3. Select between comma delimited (CSV) or tab delimited (PRN) output
format.

4. Specify the data range.
5. Specify the signals to export.
6. Click Export.

Once the data has been exported, it can be imported into spreadsheet, database,
or other data analysis programs.

Triggering Other Instruments

Triggering Other InstrumentsTriggering Other InstrumentsTriggering Other InstrumentsTriggering Other Instruments

How to trigger oscilloscopes with the logic analyzer.
� To trigger an oscilloscope with the logic analyzer
� To trigger the logic analyzer with another instrument

To trigger an oscilloscope with the logic analyzerTo trigger an oscilloscope with the logic analyzerTo trigger an oscilloscope with the logic analyzerTo trigger an oscilloscope with the logic analyzer

1. Connect a cable from the logic analyzer's output BNC to the oscilloscope's
input BNC.

2. In the oscilloscope, set up the oscilloscope measurement.
3. In the logic analyzer, choose the Trigger->Trigger BNC->Output

command.
4. In the oscilloscope, start the oscilloscope measurement.
5. In the logic analyzer, start the logic analyzer measurement.


NOTE: Terminate the BNC output into 50 ohms to ensure good signal quality.
Not terminating the signal may result in false triggering on the negative edge of
the BNC output due to the ringing on an unterminated cable.
If a 50 ohm load is not available, viewing the trigger event in the oscilloscope will
show you how to set the oscilloscope's trigger level to get the best results.

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To trigger the logic analyzer with another instrumentTo trigger the logic analyzer with another instrumentTo trigger the logic analyzer with another instrumentTo trigger the logic analyzer with another instrument

1. Connect a cable from the other instrument's output BNC to the logic
analyzer's input BNC.

2. In the logic analyzer, choose the Trigger->Trigger BNC->Input from BNC-
>Agilent Scope or Trigger->Trigger BNC->Input from BNC->TTL
command.

3. In the other instrument, set up the other instrument's measurement.
4. In the logic analyzer, start the logic analyzer measurement.
5. In the other instrument, start the measurement.

Reference

ReferenceReferenceReferenceReference

Describes windows, menus, dialogs, error messages, and specifications and
characteristics.

� Windows - Describes the LogicWave windows.
� Menus - Describes the menus.
� Toolbars - Describes the toolbars.
� Dialogs - Describes the dialogs opened by a command or toolbar button.
� Error Messages - Tells you what caused the message and how to remedy

the situation.
� Specifications and Characteristics - for LogicWave.

Windows

WindowsWindowsWindowsWindows

Describes the LogicWave windows.
� Waveform Window
� Listing Window
� Secondary Waveform Display
� Secondary Listing Display
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Waveform WindowWaveform WindowWaveform WindowWaveform Window

When timing mode sampling is selected, the Waveform window is displayed.
The left pane shows the signals and buses that have been set up.  The middle
pane is used to set up trigger conditions.  The right pane displays the captured
signal values.
See AlsoSee AlsoSee AlsoSee Also

� To group signals into buses
� To hide signals/buses
� To rename signals/buses
� To reorder signals/buses in the display
� To set up timing mode triggers
� To locate a bus pattern
� To scale the waveform display
� To use the X and O markers
� To specify waveform colors

Listing WindowListing WindowListing WindowListing Window
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When state mode sampling is selected, the Listing window is displayed.
The first heading row shows the signals and buses that have been set up.  The
second heading row is used to set up trigger conditions.  The remaining body
rows display the captured signal values.
The left-most column shows captured state numbers, and the right-most column
shows time information.
See AlsoSee AlsoSee AlsoSee Also

� To group signals into buses
� To hide signals/buses
� To rename signals/buses
� To reorder signals/buses in the display
� To set up state mode triggers
� To locate a bus pattern
� To use the X and O markers
� To display absolute time information
� To display relative time information

Secondary Waveform DisplaySecondary Waveform DisplaySecondary Waveform DisplaySecondary Waveform Display

Secondary windows provide another view of the captured data.  For example,
you can view state mode data as waveforms, or you can view different signals or
data.
See AlsoSee AlsoSee AlsoSee Also

� To hide signals/buses
� To reorder signals/buses in the display
� To locate a bus pattern
� To scale the waveform display
� To use the X and O markers
� To specify waveform colors
� Secondary Listing Display
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Secondary windows are not saved in logic analyzer setup files.
Secondary Listing DisplaySecondary Listing DisplaySecondary Listing DisplaySecondary Listing Display

Secondary windows provide another view of the captured data.  For example,
you can view timing mode data as numerical values, or you can view different
signals or data.
See AlsoSee AlsoSee AlsoSee Also

� To hide signals/buses
� To reorder signals/buses in the display
� To locate a bus pattern
� To use the X and O markers
� To display absolute time information
� To display relative time information
� Secondary Waveform Display

Secondary windows are not saved in logic analyzer setup files.

Menus

MenusMenusMenusMenus

Describes the menu commands and their dialogs.
� File Menu
� Bus/Signal Menu
� Trigger Menu
� Run/Stop Menu
� Data Menu
� Tools Menu
� Window Menu
� Help Menu
� System Menus
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File MenuFile MenuFile MenuFile Menu

New... Creates a new logic analyzer setup file.
Open... Opens a previously saved logic analyzer setup file.

Secondary Display windows are not restored.
Close Closes the active window after asking whether to save its

data.
Save Saves the current logic analyzer setup to a file.  If the

current setup has not already been saved, you are
prompted for a file name.  Secondary Display windows are
not saved.

Save As... Saves the current logic analyzer setup to a file that you
name.

Export... Exports the captured data in ASCII format.
Print
Preview...

Shows you what will be printed, given the current page
setup.

Print... Prints the captured data that is currently displayed.
Exit Closes the LogicWave window.



51

Bus/Signal MenuBus/Signal MenuBus/Signal MenuBus/Signal Menu

Setup... Opens the Bus/Signal Setup dialog for naming buses and
signals and setting the signal threshold.

Group Into
Bus

Groups the selected signals into a bus.

Ungroup
from Bus

Converts the selected bus into individual signals.

Expand Expands the display of the selected bus so that the signals
that make up the bus are also displayed.

Collapse Collapses the display of the selected bus so that only the
bus is displayed (and not the signals that make up the
bus).

Format Row-
>Move Up

Moves the selected bus/signals up in the display.

Format Row-
>Move Down

Moves the selected bus/signals down in the display.

Format Row-
>Hide

Hides the selected bus/signals.

Format Row-
>Show All

Displays all defined buses and signals.

Format Row-
>Properties..
.

Lets you specify the waveform color.

Rename Renames the selected signal or bus.
Name
Sequential

Renames the signals in the selected bus to
"bus_name[signal_number]" format.

Symbols... Opens the Edit Symbols dialog for defining symbolic
names that can be displayed instead of data values in the
Listing view.
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Trigger MenuTrigger MenuTrigger MenuTrigger Menu

Bus Value... Sets up to trigger on a certain value appearing on the
selected bus.

Don't Care The selected bus/signal is not used for triggering.
Rising Edge Sets up to trigger on a rising edge of the selected signal.
Falling Edge Sets up to trigger on a falling edge of the selected signal.
Either Edge Sets up to trigger on any (rising or falling) edge of the

selected signal.
High Sets up to trigger on a logic high value of the selected

signal.
Low Sets up to trigger on a logic low value of the selected

signal.
Pulse
Duration...

Sets up to trigger on a pulse width of the selected signal.

Add
"Followed
by" condition

Displays second trigger setup column for specifying
triggers on sequential events.

Add 'OR'
condition

In the synchronous sampling state mode: displays
additional trigger setup rows for specifying triggers on one
of several values.

Add 'THEN'
condition

In the synchronous sampling state mode: displays
additional trigger setup rows for specifying triggers on
sequential state events.

Reset Returns to the default trigger specification.
Occurrence
count = N...

In the synchronous sampling state mode: sets up to trigger
on the Nth occurrence of a value.

Trigger BNC-
>Off

Turns off trigger signal input from, or trigger signal output
to, other instruments (like oscilloscopes).

Trigger BNC- Sets up to receive BNC trigger signal inputs at voltage
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>Input from
BNC-
>Agilent
Scope

levels compatible with Agilent oscilloscopes.

Trigger BNC-
>Input from
BNC->TTL

Sets up to receive BNC trigger signal inputs at TTL voltage
levels.

Trigger BNC-
>Output to
BNC

Sets up to send trigger signal output to other instruments.

NOTE: Terminate the BNC output into 50 ohms to ensure
good signal quality. Not terminating the signal may result in
false triggering on the negative edge of the BNC output
due to the ringing on an unterminated cable.


Run/Stop MenuRun/Stop MenuRun/Stop MenuRun/Stop Menu

Single
Measuremen
t

Starts sampling, fills logic analyzer memory with samples
around the trigger, and stops.

Repetitive
Measuremen
t

Starts sampling, fills logic analyzer memory with samples
around the trigger, and repeats.

Stop Stops a logic analyzer measurement that is in progress, for
example, when the trigger condition is not found.

Trigger
Immediate

Ignores the trigger that is currently set up, triggers on the
first sample that is seen, fills logic analyzer memory with
samples, and stops.
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Data MenuData MenuData MenuData Menu

Sampling
Setup...

Opens the Sampling Setup dialog for specifying the logic
analyzer's sampling and trigger position.

Find Data
Value...

Finds particular values in the captured data.

Go To->X
Marker

Displays the captured samples around the X marker.

Go To->O
Marker

Displays the captured samples around the O marker.

Go To-
>Trigger

Displays the captured samples around the sample that
triggered the analyzer.

Zoom In Decreases the display's time-per-division to show less
data with better resolution.

Zoom Out Increases the display's time-per-division to show more
data with worse resolution.

Undo Last
Zoom

Returns to the time-per-division setting before the last
zoom command.

Show As Specifies whether bus values are displayed in
hexadecimal numbers, binary numbers, decimal numbers,
or symbolic values.

Demo Lets you use the user interface in demo mode with
simulated signals.
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Tools MenuTools MenuTools MenuTools Menu

Self Test... Runs the logic analyzer's performance verification self
tests.  You can run the self test while the logic analyzer is
connected to a device under test.

Communicati
ons Setup...

Opens the  Communications Setup dialog for specifying
the parallel port that the LogicWave logic analyzer is
connected to.

Customize... Opens the Customize dialog for specifying user interface
elements.

Options... Opens the Options dialog for specifying LogicWave
behavior.

Window MenuWindow MenuWindow MenuWindow Menu

Secondary
Waveform
Display

Opens a secondary, read-only version of the Waveform
display window.  The secondary window, perhaps with a
different time-per-division setting, gives you a different
view of the data.

Secondary
Listing
Display

Opens a secondary listing display window.

Cascade Displays the opened windows in an overlaid and offset
manner.

Tile
Horizontally

Displays the opened windows so that the horizontal
display space is equally divided.

Tile Vertically Displays the opened windows so that the vertical display
space is equally divided.
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Help MenuHelp MenuHelp MenuHelp Menu

Agilent
LogicWave
Help

Opens this help file.

Agilent on
the Web-
>LogicWave
Home Page

Opens the LogicWave home page on the world-wide web.

Agilent on
the Web-
>Test and
Measuremen
t

Opens the Agilent Technologies test and measurement
page on the world-wide web.

Agilent on
the Web-
>T&M
Service and
Support

Opens the Agilent Technologies service and support page
on the world-wide web.

Agilent on
the Web-
>Agilent
Technologies
Home Page

Opens the Agilent home page on the world-wide web.

About Agilent
LogicWave...

Displays product version and copyright information.
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System MenusSystem MenusSystem MenusSystem Menus

Restore Opens a window that has been minimized.
Move Lets you drag a window to a new location.
Size Lets you re-size a window.
Minimize Makes the window as small as possible.
Maximize Makes the window as large as possible.
Close Closes the window.
Next Opens and maximizes the next window.

Toolbars

ToolbarsToolbarsToolbarsToolbars

Describes the toolbars.
� Standard Toolbar
� Run/Stop Toolbar
� Data Toolbar
� Trigger Toolbar

Standard ToolbarStandard ToolbarStandard ToolbarStandard Toolbar

Creates a new logic analyzer setup file.
Opens a previously saved logic analyzer setup file.
Saves the current logic analyzer setup to a file.
Prints the currently displayed data.
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Run/Stop ToolbarRun/Stop ToolbarRun/Stop ToolbarRun/Stop Toolbar

Starts sampling, fills logic analyzer memory with samples
around the trigger, and stops.
Starts sampling, fills logic analyzer memory with samples
around the trigger, and repeats.
Stops a logic analyzer measurement that is in progress, for
example, when the trigger condition is not found.
Ignores the trigger that is currently set up, triggers on the
first sample that is seen, fills logic analyzer memory with
samples, and stops.
Opens the Sampling Setup dialog for choosing
asynchronous or synchronous sampling (in other words,
timing or state analysis).
Opens the Bus/Signal Setup dialog for naming buses and
signals and setting the signal threshold.

Data ToolbarData ToolbarData ToolbarData Toolbar

Centers the trigger point in the data display.
Centers the X marker reference point in the display.
Centers the O marker reference point in the display.
Searches for a value in the captured data.
Undoes the last zoom command.

Trigger ToolbarTrigger ToolbarTrigger ToolbarTrigger Toolbar

Sets up a bus value trigger on the selected bus.
Triggers on a rising edge of the selected signal.
Triggers on a falling edge of the selected signal.
Triggers on any edge of the selected signal.
Triggers on a high value of the selected signal.
Triggers on a low value of the selected signal.
Triggers on any value of the selected signal.  In other
words, you don't care what the signal value is.
Sets up a pulse duration trigger on the selected signal.
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Dialogs

DialogsDialogsDialogsDialogs

Describes the dialogs.
� Bus/Signal Setup
� Communications Setup
� Customize
� Options
� Sampling Setup
� Time Period Setup

Bus/Signal SetupBus/Signal SetupBus/Signal SetupBus/Signal Setup

Add
Bus/Signal

Adds a new bus/signal to the list.

Delete
Bus/Signal

Deletes the selected bus/signal from the list.

Delete All Deletes all buses/signals from the list.
Restore
Defaults

Sets up the default bus/signal names.

Assignment
Count

Shows the number of bus/signals that a logic analyzer
channel has been assigned to.

See AlsoSee AlsoSee AlsoSee Also

� To assign bus/signal names to the logic analyzer probes
� To locate a bus pattern
� To group signals into buses
� To rename signals
� To reorder signals/buses in the display
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� Bus/Signal Menu Commands
� Standard Toolbar

Communications SetupCommunications SetupCommunications SetupCommunications Setup

Search Searches for interfaces that can be used with LogicWave.
Connect Connects to the selected port and device.
Work Offline Opens the LogicWave user interface without connecting to

the logic analyzer.  You can work offline by loading
previously saved logic analyzer setups

See AlsoSee AlsoSee AlsoSee Also

� To recall logic analyzer setups
CustomizeCustomizeCustomizeCustomize

The Toolbars TabThe Toolbars TabThe Toolbars TabThe Toolbars Tab

This dialog lets you change the look of toolbars and create new toolbars.
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The Commands TabThe Commands TabThe Commands TabThe Commands Tab

This dialog lets you move buttons to different toolbars.
OptionsOptionsOptionsOptions

To change an option, select it; then select the new property value.
The options and their effects are:
Option Effect
Perform Self Test on Startup
Welcome Dialog

You can turn these off so that the
LogicWave application starts faster.
When the Welcome window is not
shown, the last configuration is
automatically used.

Use long bus/signal names in
Waveform

These options change the default
pod/channel signal names from
Pod#:Ch# format to P#C# format.



62

Use long bus/signal names in Listing
Edge overriding Bus trigger warning
Bus with edge edit warning

You cannot trigger on a bus value and
on an edge of one of the bus signals at
the same time.  These options let you
turn off the warnings.

Bus with clock, range N/A warning When using clock bits in a bus, you
cannot set up to trigger on a range of
values.  This option lets you turn off the
warning.

Clock bits hidden in state mode You can turn this off to include the pod
clock channels in the state mode Listing
window.

Bad duration will be autoset You can select whether bad trigger
durations will be automatically
corrected.  A trigger duration can
become bad when the sample period is
changed.  The minimum trigger duration
depends on whether it is a GREATER
THAN condition or a LESS THAN
condition:

� In a GREATER THAN condition,
the minimum trigger duration is
the sample period (except when
the sample period is 4 ns, the
minimum trigger duration is 8
ns).

� In a LESS THAN condition, the
minimum trigger duration is 2
times the sample period (except
when the sample period is 4 ns,
the minimum trigger duration is
16 ns).

In both GREATER THAN and LESS
THAN conditions, the maximum trigger
duration is 1,048,587 times sample
period.

Base mode change for edit warning When you add bits to a bus, then edit
the trigger, the number base is changed
to binary while editing.  This option lets
you turn off the warning.

I/O performance warning This warning tells you how to improve
the performance of logic analyzer I/O by
changing the parallel port transfer mode
in the PC BIOS.  This option lets you
turn off the warning.
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The Extended Capabilities Port (ECP) is
by far the best transfer mode setting for
LogicWave because it is the fastest and
the most versatile. Parallel ports set for
ECP mode can also operate in Output
Only (Standard Parallel Port, or SPP) or
Bi-directional (PS/2) mode if necessary.
This enables the host PC to continue to
communicate with other parallel port
hardware peripherals that may only
support SPP or PS/2 transfer modes. In
other words, you don't have to worry
about breaking communications with
your printer by changing a parallel port�s
CMOS settings to ECP mode.
Also, there is often another CMOS
setting available called ECP+EPP,
where the ECP port can operate in EPP
mode. That is an acceptable setting for
LogicWave because it will see the port
as an ECP port and operate in ECP
mode.
There is a possibility that the host PC
will be set for ECP mode transfers, but
a communication test done by
LogicWave at startup will fail due to the
PC�s mother board configuration with
respect to the parallel port hardware. In
this case, LogicWave will force the ECP
port to operate in bi-directional mode
and reliably communicate with the
analyzer.

Connection options at startup Specifies whether the connection
options are displayed at startup.
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Sampling SetupSampling SetupSampling SetupSampling Setup

Timing Mode
(Asynchrono
us Clock)

Contains the options for setting up timing mode sampling.

State Mode
(Synchronou
s Clock)

Contains the options for setting up state mode sampling.

General Contains the options for setting up sampling signal
threshold voltages and specifying the trigger position.

See AlsoSee AlsoSee AlsoSee Also

� State analysis vs. timing analysis
� To set the logic analyzer threshold voltage
� To select a timing or state analyzer
� To specify the trigger position
� Data Menu Commands
� Standard Toolbar
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Time Period SetupTime Period SetupTime Period SetupTime Period Setup

Indefinite
time

When the second event occurs any amount of time after
the first event, the logic analyzer will trigger.

Greater than
time

When the second event occurs more than the specified
amount of time after the first event, the logic analyzer will
trigger.  If the second event occurs within the time period,
the logic analyzer will not trigger.
The minimum time period is either equal to the sample
period or the absolute minimum of 8 ns.

Less than
time

When the second event occurs within the time period after
the first event, the logic analyzer will trigger.  If the second
event occurs after the time period, the logic analyzer will
not trigger.
The minimum time period is either twice the sample period
or the absolute minimum of 16 ns.

Time Period The time must be a multiple of the sample period.  If the
time you enter is not a multiple of the sample period, it will
be rounded up to the nearest multiple.

See AlsoSee AlsoSee AlsoSee Also

� To set up timing mode triggers

Error Messages

Error MessagesError MessagesError MessagesError Messages

Describes the message and how to remedy the situation.
� Device connection failed
� LogicWave is currently in Demo mode
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Device connection failedDevice connection failedDevice connection failedDevice connection failed

Search for
the device

Looks for the LogicWave logic analyzer on the PC's
parallel ports.

Work offline Lets you use the LogicWave's user interface for analyzing
previously captured and saved data.

Demo
(offline)

Lets you use the LogicWave's user interface.

Set as
default action
on
connection
failure at
startup

When checked, makes the selected action the default
whenever there is a connection failure at startup.

Continue Starts the LogicWave logic analyzer user interface as
specified.

Exit Closes the dialog, and doesn't start the LogicWave logic
analyzer user interface.

LogicWave is currently in Demo modeLogicWave is currently in Demo modeLogicWave is currently in Demo modeLogicWave is currently in Demo mode

This message dialog appears when the application is in demo mode and you
open a previously saved file that contains real data.
Connect to
analyzer

Looks for the LogicWave logic analyzer on the PC's
parallel ports .

Work Offline Lets you use the LogicWave's user interface for analysis of
previously captured and saved data.

Continue in
Demo mode

Lets you use the LogicWave's user interface in demo
mode (without the data).
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Specifications and Characteristics

Specifications and CharacteristicsSpecifications and CharacteristicsSpecifications and CharacteristicsSpecifications and Characteristics

Describes the specifications, characteristics, and other characteristics and
requirements of the LogicWave logic analyzer.

� LogicWave Specifications
� LogicWave Characteristics
� About the Probe Cable
� Signal Requirements

See AlsoSee AlsoSee AlsoSee Also

� What is a Specification?
� What is a Characteristic?

LogicWave SpecificationsLogicWave SpecificationsLogicWave SpecificationsLogicWave Specifications

Maximum state clock: 100 MHz
Threshold Accuracy: ±(100 mV + 3% of threshold setting)
Setup/Hold Time: 4.0/0 ns fixed
LogicWave CharacteristicsLogicWave CharacteristicsLogicWave CharacteristicsLogicWave Characteristics

� General Information
� Probes (at end of flying lead set)
� State Analysis
� Timing Analysis
� Triggering
� Operating Environment Characteristics

General InformationGeneral InformationGeneral InformationGeneral Information

State/timing channels: 34
Memory depth: 128K timing, 64K state
User interface: Windows® 95/98/NT/2000, PC-hosted

(runs as an application on any
Pentium® or better, desktop or laptop,
with a minimum display resolution of
800x600 -- large fonts are not
supported)

"WYDIWYC" timing trigger: "What you draw is what you capture"
visual timing trigger setup

Printers: Shared with the host PC - can print to
any local or network printer supported
by the PC

Probing: 100 kohms, 1.5 pF
Dimensions: 11.5" x 9" x 2.5" (29.1 x 22.8 x 6.3 cm)
Weight: 4.5 pounds (2.1 kg)
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I/O Ports: Enhanced Parallel connection to PC for
fast display update rates, Trigger
IN/OUT BNC

Supported file formats for screen shots: Use Ctrl + Alt + PrintScreen to create
bitmap

Configuration and data files: Encoded in binary format (stored to or
loaded from host PC); can export
acquired data to an ASCII formatted file.

Probes (at end of flying lead set)Probes (at end of flying lead set)Probes (at end of flying lead set)Probes (at end of flying lead set)

Input resistance: 100 kohm ±2%
Resistive tip capacitance: 1.5 pF
Minimum input voltage swing: 500 mV peak-to-peak
Threshold accuracy: ±(100 mV + 3% of threshold setting)
Threshold range: TTL, ECL, ±6.0 V, adjustable in 50 mV

increments
Maximum input voltage: ±40 V peak
State AnalysisState AnalysisState AnalysisState Analysis

Minimum state clock pulse width: 3.5 ns
Time tag resolution: 8ns or 0.1% (whichever is greater)
Maximum time count between states: 34 seconds
Clock qualifiers setup/hold: 4.0/0 ns fixed
Timing AnalysisTiming AnalysisTiming AnalysisTiming Analysis

Maximum timing sample rate: 250 MHz
Sample period accuracy: ±0.01% of sample period
Channel-to-channel skew: 2 ns typical, 3 ns max
Timing interval accuracy: ±(sample period accuracy + channel-to-

channel skew + 0.01% of time interval
reading ± one sample period)

TriggeringTriggeringTriggeringTriggering

Sequencer speed: 125 MHz maximum
State sequence levels: 3
Timing sequence levels: 2
Port In delay: 35 ns between rising edge on Port In

BNC and don't care logic analyzer
trigger

Port Out delay: 120 ns between logic analyzer trigger
and rising edge on Port Out BNC
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Operating Environment CharacteristicsOperating Environment CharacteristicsOperating Environment CharacteristicsOperating Environment Characteristics

Temperature: Instrument: 0°C to 55°C (+32°F to
131°F)
Disk media: 10°C to 40°C (+50°F to
104°F)

Humidity: Up to 95% relative humidity at 40°C
Altitude: 4,572 m (15,000 ft)
About the Probe CableAbout the Probe CableAbout the Probe CableAbout the Probe Cable

The probe cable contains 18 signal lines, 17 chassis ground lines, two serial lines
for communications with analysis probes, and 2 lines that carry minimal power for
demo "device under test" systems.
The cable ground lines are chassis (earth) grounds and not "floating" grounds. All
the lines are woven into a flat ribbon that is 4.5 feet long.

Signal RequirementsSignal RequirementsSignal RequirementsSignal Requirements

� Minimum Signal Amplitude
� Signal Loading
� Maximum Probe Input Voltage
� Overdrive

Minimum Signal AmplitudeMinimum Signal AmplitudeMinimum Signal AmplitudeMinimum Signal Amplitude

Any signal line you intend to probe with the logic analyzer probes must supply a
minimum voltage swing of 500 mV to the probe tip. If you measure signal lines
with a smaller voltage swing, you may not get reliable results. The minimum input
overdrive is the greater of 250 mV or 30% of signal amplitude.
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Signal LoadingSignal LoadingSignal LoadingSignal Loading

Any probed signal line must be able to handle the following load:

If  the signal cannot handle this load, the target system may malfunction.
Maximum Probe Input VoltageMaximum Probe Input VoltageMaximum Probe Input VoltageMaximum Probe Input Voltage

The maximum probe input voltage of each logic analyzer probe is 40 volts peak.
OverdriveOverdriveOverdriveOverdrive

Overdrive is the amount a signal must exceed the threshold voltage for the logic
analyzer to detect a change in logic level. For the LogicWave logic analyzer,
overdrive is 250 mV or 30% of signal peak-to-peak amplitude, whichever is
greater.
For example, given a 3.3 volt CMOS signal (low = 0V, high = 3.3 V) the optimal
threshold is 1.65 V (50%). If the threshold is set less than 1.0 V or greater than
2.3 V, then a timing acquisition might show excessive channel-to-channel skew.
For a state acquisition, the analyzer's setup and hold requirements might not be
met.

The overdrive amount is specified as the greater of 250 mV or 30% of the signal
amplitude because it has two purposes. The 250 mV ensures reliable switching
or state detection. The 30% of amplitude ensures the threshold is reasonably
centered within the waveform in order to minimize channel-to-channel skew (tPHL
vs tPLH).
What is a Specification?What is a Specification?What is a Specification?What is a Specification?

A specification is a numeric value, or range of values, that bounds the
performance of a product parameter.  The product warranty covers the
performance of parameters described by specifications.  Products shipped from
the factory meet all specifications.  Additionally, products sent to Agilent
Customer Service Centers for calibration, and returned, meet all specifications.
Specifications are verified by calibration procedures.
What is a Calibration Procedure?What is a Calibration Procedure?What is a Calibration Procedure?What is a Calibration Procedure?

Calibration procedures verify that products or systems operate within the
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specifications.  Parameters covered by specifications have a corresponding
calibration procedure.  Calibration procedures include both performance tests
and system verification procedure.  Calibration procedures are traceable and
must specify adequate calibration standards.
Calibration procedures verify products meet the specifications by comparing
measured parameters against a pass-fail limit. The pass-fail limit is the
specification less any required guardband.
The term "calibration" refers to the process of measuring parameters and
referencing the measurement to a calibration standard rather than the process of
adjusting products for optimal performance.
What is a Characteristic?What is a Characteristic?What is a Characteristic?What is a Characteristic?

Characteristics describe product performance that is useful in the application of
the product, but that is not covered by the product warranty.  Characteristics
describe performance that is typical of the majority of a given product, but not
subject to the same rigor associated with specifications.  Characteristics are
verified by function tests.
What is a Function Test?What is a Function Test?What is a Function Test?What is a Function Test?

Function tests are quick tests designed to verify basic operation of a product.
Function tests include operator's checks and operation verification procedures.
An operator's check is normally a fast test used to verify basic operation of a
product. An operation verification procedure verifies some, but not all,
specifications, and often at a lower confidence level than a calibration procedure.

Concepts

ConceptsConceptsConceptsConcepts

How logic analyzers work and how they compare to other instruments.
� Logic analyzers vs. oscilloscopes
� State analysis vs. timing analysis
� State analyzer sampling, OR'ed clocks
� State analyzer sampling, qualified clock

Answers to common questions about LogicWave.
� Frequently Asked Questions

Logic analyzers vs. oscilloscopesLogic analyzers vs. oscilloscopesLogic analyzers vs. oscilloscopesLogic analyzers vs. oscilloscopes

A logic analyzer is an instrument that captures digital signals.  It's like a digital
oscilloscope, except that it captures logic high and logic low values instead of
many voltage levels.
For each channel (or probe) in a digital oscilloscope, many comparators are used
to give high resolution on the voltage measured.
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For each channel in a logic analyzer, only one comparator is used to detect a
logic high or low.  With the same number of comparators as an oscilloscope, a
logic analyzer can capture data on many more channels.

Also, in order to capture the high-frequency, analog component of signals, an
oscilloscope must sample at a faster rate than a logic analyzer (although both
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must sample at a rate faster than the highest frequency of the signals they
measure).  Given the same amount of memory to store samples, a logic analyzer
can capture data over a greater time period than a digital oscilloscope.

An oscilloscope gives a highly detailed view of the parametrics of a few critical
signals while a logic analyzer displays the functional relationship of a larger
number of signals.
State analysis vs. timing analysisState analysis vs. timing analysisState analysis vs. timing analysisState analysis vs. timing analysis

What is a Timing Analyzer?What is a Timing Analyzer?What is a Timing Analyzer?What is a Timing Analyzer?

In timing mode, samples are acquired from the device under test at regular
intervals, such as every 4 nanoseconds.  An internal clock is used for sampling.
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What is a State Analyzer?What is a State Analyzer?What is a State Analyzer?What is a State Analyzer?

In state mode, an event in the device under test, such as a rising edge of a clock
signal, indicates when the logic analyzer should take a sample.

NOTE: There is a special clock channel on each pod that is labeled "CLK".
These are the only channels that can be used for state mode sampling signals.

You can use one or both clock channels to provide state mode sampling signals,
or you can use the signal on one clock channel to enable or disable the sampling
signal on the other clock channel.
State analyzer sampling, OR'ed clocksState analyzer sampling, OR'ed clocksState analyzer sampling, OR'ed clocksState analyzer sampling, OR'ed clocks

Two signals from the device under test are combined to tell the logic analyzer
when to sample.
State analyzer sampling, qualified clockState analyzer sampling, qualified clockState analyzer sampling, qualified clockState analyzer sampling, qualified clock

One signal from the device under test enables/disables the sampling clock on the
other signal.

Frequently Asked QuestionsFrequently Asked QuestionsFrequently Asked QuestionsFrequently Asked Questions

1. What is a logic analyzer?
2. How does a logic analyzer work?
3. What is Timing Mode?
4. What is State Mode?
5. What are T, X, and O?
6. What is a pod?
7. What is a channel?
8. What are the color-coded symbols next to a pod/channel?
9. What is a Trigger?
10. How do I specify the trigger event?
11. Can I display state mode data in waveform format?
12. Can I display timing mode data in listing format?
13. What is an external trigger?
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14. What are symbols?

What is a logic analyzer?What is a logic analyzer?What is a logic analyzer?What is a logic analyzer?

A logic analyzer is an instrument that captures and displays digital signals from a
device under test.
A logic analyzer is like an oscilloscope, except that it only displays two voltage
levels (a logic high or 1 and a logic low or 0) instead of many voltage levels.
Also, logic analyzers have far more channels for analysis than oscilloscopes.
The LogicWave logic analyzer has 34 channels.
Because a logic analyzer only captures 1s and 0s, its sample rate can be slower
than an oscilloscope that needs to capture more voltage detail.  Consequently, a
logic analyzer can capture a greater amount of overall execution time.
Back to TopBack to TopBack to TopBack to Top


How does a logic analyzer work?How does a logic analyzer work?How does a logic analyzer work?How does a logic analyzer work?

A logic analyzer samples signal values in the device under test and stores those
values in its memory.  It watches the samples for an event that you identify (the
trigger event) to determine when to store sampled data into memory.
Back to TopBack to TopBack to TopBack to Top


What is Timing Mode?What is Timing Mode?What is Timing Mode?What is Timing Mode?

Timing mode is when the logic analyzer acquires samples from the device under
test asynchronously, that is, at regular intervals.  The sampling interval or sample
period is set by the user.
Back to TopBack to TopBack to TopBack to Top


What is State Mode?What is State Mode?What is State Mode?What is State Mode?

State mode is when the logic analyzer acquires samples from the device under
test synchronously, in other words, when a signal or signals from the device
under test indicate when to acquire a sample. For example, the logic analyzer
might take a sample whenever there is a rising edge on a signal from the device
under test.
Back to TopBack to TopBack to TopBack to Top


What are T, X, and O?What are T, X, and O?What are T, X, and O?What are T, X, and O?

T, X, and O are markers.  T marks the trigger event and cannot be moved.  X
and O are markers that you can place anywhere in the captured data.  Markers
let you quickly return to data of interest using the Go To Marker commands.
Back to TopBack to TopBack to TopBack to Top
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
What is a pod?What is a pod?What is a pod?What is a pod?

A pod is a collection of logic analyzer channels on a single connector.
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What is a channel?What is a channel?What is a channel?What is a channel?

A (logic analysis) channel is a single line of input to the logic analyzer.  Each
channel corresponds to a lead that is connected to the device under test.  Each
channel is used to acquire one and only one signal from the device under test.
Back to TopBack to TopBack to TopBack to Top


What are the color-coded symbols next to a pod/channel?What are the color-coded symbols next to a pod/channel?What are the color-coded symbols next to a pod/channel?What are the color-coded symbols next to a pod/channel?

The color indicates the channel.  It matches the colors on the end of the probe
cable.
The symbols are activity indicators.  They show the level of the signal(s) that the
pod/channel is connected to: high, low, or changing between high and low.
Back to TopBack to TopBack to TopBack to Top


What is a Trigger?What is a Trigger?What is a Trigger?What is a Trigger?

A trigger is the event you tell the logic analyzer to look for and capture data
around.  For example, you may want to trigger on an edge in order to see the
events that lead up to it and the events that happen after it.  The captured trigger
event becomes a reference point in the data display.
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How do I specify the trigger event?How do I specify the trigger event?How do I specify the trigger event?How do I specify the trigger event?

Click on a bus or signal's trigger button to select the condition to trigger on.
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Can I display state mode data in waveform format?Can I display state mode data in waveform format?Can I display state mode data in waveform format?Can I display state mode data in waveform format?

Yes.  You can open a Secondary Waveform Display window to display state
mode data in listing format.
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Can I display timing mode data in listing format?Can I display timing mode data in listing format?Can I display timing mode data in listing format?Can I display timing mode data in listing format?

Yes.  You can open a Secondary Listing Display window to display timing mode
data in waveform format.
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What is an external trigger?What is an external trigger?What is an external trigger?What is an external trigger?

An external trigger is a signal outside the logic analyzer that is used to
synchronize measurements between instruments.  For example, the logic
analyzer can be armed (activated) by a signal that comes from another
instrument, or when the logic analyzer triggers, it can output a signal to another
instrument.  Logic analyzers are commonly used to trigger oscilloscopes.
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What are symbols?What are symbols?What are symbols?What are symbols?

Symbols are names assigned to particular bus/signal values.  Symbols in a
display of captured data values are easy to read.  Also, symbols make it easy to
set up triggers on particular bus/signal values.
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Setup and Quick ReferenceSetup and Quick ReferenceSetup and Quick ReferenceSetup and Quick Reference

The Agilent LogicWave Setup and Quick Reference Card shows you how to
connect the logic analyzer to your PC and install software.
Agilent LogicWave Setup and Quick Reference Card (  PDF)
If you do not have the Adobe Acrobat
Reader necessary for viewing PDF
documentation, download your free
Acrobat Reader now.

GlossaryGlossaryGlossaryGlossary

activity indicators
Symbols next to logic analyzer channels that indicate whether a signal is a
logic-high, logic-low, or whether the signal is changing between highs and
lows.

arming signal
An enabling signal.  For example, if an external trigger signal is connected to
the logic analyzer's BNC input, it can be used to enable the logic analyzer to
trigger.

asynchronous sampling
When the logic analyzer acquires samples from the device under test
asynchronously, that is, at regular intervals, such as every 100 ns.  Also
known as timing mode.
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bus/signal
Names assigned to the logic analyzer channels.  Typically, these are the bus
or signal names in the device under test.

captured data
Signal values that have been sampled by the logic analyzer and stored in its
memory.

channel
A single line of input to the logic analyzer.  Each channel corresponds to a
lead that is connected to the device under test.  Each channel is used to
acquire one and only one signal from the device under test.

CLK channel
A logic analyzer input channel that can be used to determine the analyzer's
sampling.

device under test (DUT)
The system under development whose digital signals are captured by the
logic analyzer.

external trigger
A signal outside the logic analyzer that is used to synchronize measurements
between instruments.  For example, the logic analyzer can be armed
(activated) by a signal that comes from another instrument, or when the logic
analyzer triggers, it can output a signal to another instrument.  Logic
analyzers are commonly used to trigger oscilloscopes.

logic analyzer
An instrument that captures and displays digital signal values.  A logic
analyzer is like an oscilloscope, except that it only displays two voltage levels
(a logic high or 1 and a logic low or 0) instead of many voltage levels.  Also,
logic analyzers have far more channels for analysis than oscilloscopes.  The
LogicWave logic analyzer has 34 channels.  Because a logic analyzer only
captures 1s and 0s, its sample rate can be slower than an oscilloscope that
needs to capture more voltage detail.  Consequently, a logic analyzer can
capture a greater amount of overall execution time.

marker
A relocatable reference point in the data display.  LogicWave has T, X, and O
markers.  T marks the trigger event and cannot be moved.  X and O are
markers that you can place anywhere in the captured data.  Markers let you
quickly return to data of interest using the Go To Marker commands.
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oscilloscope
An instrument that captures and displays analog signal values (that is, many
voltage levels).

pod
A collection of 16 logic analyzer probe channels.

repetitive measurement
A measurement in which the logic analyzer's trigger condition is searched for,
and data storage is filled, repetitively.

sample period
The period at which the logic analyzer samples signals.  The sample period
can be based on an internal sampling clock (also known as timing analysis or
asynchronous sampling).  Or, the sampling can be based on a signal in the
device under test (also known as state analysis or synchronous sampling).

sampled data
Signal values that are sampled by the logic analyzer (not neccessarily
stored).

sampling
The process by which the logic analyzer looks at digital signals.

sampling clock
A clock signal used to determine the logic analyzer's sampling.

signal threshold
See threshold voltage.

single measurement
A measurement in which the logic analyzer's trigger condition is searched for,
and data storage is filled, once.

state analyzer
A logic analyzer that samples based on a clock signal in the device under
test.

state mode
When the logic analyzer acquires samples from the device under test
synchronously, in other words, when a signal or signals from the device
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under test indicate when to acquire a sample. For example, the logic analyzer
might take a sample whenever there is a rising edge on a signal from the
device under test.  Typically, the signal used to set up the sampling is a state
machine or microprocessor clock signal.  Also known as synchronous
sampling.

stop measurement
Stops the measurement currently in progress.

symbols
Names assigned to particular bus/signal values.  Symbols in a display of
captured data values are easy to read.  Also, symbols make it easy to set up
triggers on particular bus/signal values.

synchronous sampling
When the logic analyzer acquires samples from the device under test
synchronously, in other words, when a signal or signals from the device
under test indicate when to acquire a sample. For example, the logic analyzer
might take a sample whenever there is a rising edge on a signal from the
device under test.  Typically, the signal used to set up the sampling is a state
machine or microprocessor clock signal.  Also known as state mode.

target system
See device under test.

threshold voltage
The voltage level that the signal must cross before the logic analyzer
recognizes a change in voltage levels.  When TTL is selected, the threshold
voltage is +1.5 volts.   When CMOS is selected, the threshold voltage is
+1.65 volts.   When ECL is selected, the threshold voltage is -1.3 volts.

timing analyzer
A logic analyzer that samples at regular intervals based on an internal clock
signal.

timing mode
When the logic analyzer acquires samples from the device under test
asynchronously, that is, at regular intervals, such as every 100 ns.  Also
known as asynchronous sampling.

trigger
The event about which acquired data is stored; in other words, the event that
you are looking for.  For example, you may want to trigger on an edge in
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order to see the events that lead up to it and the events that happen after it.
The event that triggers the logic analyzer becomes a reference point in the
data display.

trigger position
The location of the trigger event in trace memory.  If you want to view data
after, about, or before the trigger event, you set the trigger position to the
start, center, or end of trace memory, respectively.

trigger specification
Specifies when the logic analyzer stores sampled data. Usually the trigger
specification is made in terms of sampled data. For example, "store sampled
data when the interrupt signal becomes active."

Technical SupportTechnical SupportTechnical SupportTechnical Support

For the most up-to-date information on Agilent Direct and Call Centers, local
sales offices, service center locations, and telephone numbers, please visit the
Agilent Technologies Test & Measurement Contact Us web site.
Agilent Direct and Call CentersAgilent Direct and Call CentersAgilent Direct and Call CentersAgilent Direct and Call Centers

Agilent Direct and Call Centers are an additional telephone resource for you. In
many parts of the world, you can contact this telephone resource center for
technical information and assistance over the telephone. You can order some
products and accessories, ask for literature or, in some cases, request products
for evaluation usage. The support engineers at Agilent Direct and the Call
Centers go through the same rigorous technical training process that your Field
Engineer does. And, your team works together to be sure that you are receiving
the best support possible from any one of our Agilent Direct and Call Centers.
Agilent Local Sales OfficesAgilent Local Sales OfficesAgilent Local Sales OfficesAgilent Local Sales Offices

Agilent Technologies sales offices are located around the world in over 110
countries. Your Local Sales office is where you will find your Field Sales
Engineer and their technical and administrative support staff. Some sales offices
host training classes and seminars and many offer onsite product
demonstrations. Your nearest sales office will put you in touch with your Field
Sales Engineer. When you call, be sure to tell your Sales Office operator that you
wish to speak with a Test and Measurement Field Sales Engineer and provide
your company and city name.
Service InformationService InformationService InformationService Information

Agilent Technologies can provide you with both onsite and bench repair and
calibration of your Test and Measurement equipment. Our Customer Engineers
are highly trained professionals available to help you at your site both installing
and maintaining your Test and Measurement products. Contact your Customer
Engineer through your local Agilent sales office.
Our bench repair facilities are also located around the world. You can arrange to
have a single repair or calibration or you can set up a repair and calibration
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contract with your service center which will save you time and money. If you
need help with the repair or calibration of a product, be sure to have the model
number and serial number of your scope ready when you call your service center
so that we can better serve you.
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